Audio Wiedergabe

german

#1

Hallo,

auf unseren UCC-Systemen können “normal” Nutzer keinen Ton wiedergeben.
Nur “root” kann das. Ich habe auf einem System per “addgroup BENUTZERNAME audio” einen Nutzer mal hinzugefügt. Der kann dann Ton abspielen.
Nun will ich natürlich nicht jedem Nutzer an jedem Platz so die Rechte zur Tonwiedergabe verschaffen.

Gibt es dafür eine elegante Lösung?

Viele Grüße
Torsten


#2

Hallo,

das von Ihnen beschriebene ist auf jeden Fall kein Standardverhalten.

  • Welche UCC Version wird in was für einem Szenario eingesetzt? Sind das UCC-Desktops oder Thinclients?
  • Läuft ein pulseaudio Prozess für den angemeldeten Benutzer?
  • Gibt es Hinweise auf pulseaudio Probleme in der /var/log/syslog?

#3

Hallo,

wir nutzen UCC-Desktops 2.1 auf “moderneren” Standard-PCs (mit HDMI und analog Audio)
Das Syslog sagt:

Aug 31 13:35:55 pkr-stg01 pulseaudio[5224]: [pulseaudio] core-util.c: Failed to create secure directory (/home/NUTZER/.config/pulse): Keine Berechtigung
Aug 31 13:35:55 pkr-stg01 pulseaudio[5221]: [pulseaudio] main.c: Start des Daemons fehlgeschlagen.
Aug 31 13:35:55 pkr-stg01 rtkit-daemon[2372]: Successfully made thread 5249 of process 5249 (n/a) owned by ‘2009’ high priority at nice level -11.
Aug 31 13:35:55 pkr-stg01 rtkit-daemon[2372]: Supervising 4 threads of 2 processes of 2 users.


#4

Hallo,

ich erinnere mich, dass Sie in einem älteren Thread das Einbinden der Homeverzeichnisse über NFS versucht haben. Ich würde tippen, dass das Berechtigungsproblem Failed to create secure directory (/home/NUTZER/.config/pulse): Keine Berechtigung daher rührt.

Auf meinem UCC 2.1 sehen die Berechtigungen für den Benutzer univention so aus:

# ls -la /home/univention/.config/
drwx------  7 univention Domain Users  4096 Aug 31 14:46 .
drwx--x--x 17 univention Domain Users  4096 Aug 31 14:46 ..
drwxr-xr-x  2 univention Domain Users  4096 Aug 31 14:44 dconf
drwxr-xr-x  2 univention Domain Users  4096 Aug 31 14:44 gtk-3.0
drwx------  3 univention Domain Users  4096 Aug 31 14:44 ibus
drwxr-xr-x  2 univention Domain Users  4096 Aug 31 14:46 oxygen-gtk
drwx------  2 univention Domain Users  4096 Aug 31 14:44 pulse
-rw-r--r--  1 univention Domain Users 18766 Aug 31 14:46 Trolltech.conf
-rw-------  1 univention Domain Users   639 Aug 31 14:44 user-dirs.dirs
-rw-r--r--  1 univention Domain Users     5 Aug 31 14:44 user-dirs.locale

#5

Hallo,

danke für die Antwort.
Ich habe noch eine Weile weiter probiert. Vielleicht war ich einfach nur immer zu “blind” um alle Lautstärkeregler des Mixers ganz hoch zuschieben.
Jetzt scheint es zu funktionieren.

Danke für die Mühe.