Apache mod_proxy_wstunnel

german

#1

Hallo liebes Forum

gibt es eine Möglichkeit unter UCS 4.1 für den Apache2 2.2.22 Webserver das websocket modul mod_proxy_wstunnel zu installieren (um websocket verbindungen über proxy zu konfigurieren)
bzw wann wird in UCS Apache Version >= 2.4.5 gehoben ? (hier sollte es ja schon dabei sein)

Danke & LG


#2

Hallo,
das Modul “mod_proxy_wstunnel” kann man selbst bauen und dann in den entsprechenden Module-Ordner vom Apache kopieren.
Hier eine Anleitung wie das zu bewerkstelligen ist: gist.github.com/vitkin/6661683
Unter dem Link ist auch ein Verweis auf den originalen Patch zu dem Thema zu finden.

Bzgl. der Apache-Version verweise ich auf die Quellen für UCS 4.2, welche laut Roadmap im Herbst 2016 erscheinen soll. Dort ist aktuell Version 2.4.10 drin.
Siehe hier: updates-test.software-univentio … 2-0/amd64/
-> apache2_2.4.10-10+deb8u5A~4.2.0.201609061628_amd64.deb


#3

Danke für die Info, ich denke ich kann das mit dem Release 4.2 abwarten - vielleicht teste ich den manuellen weg wenn ich Zeit habe dann gebe ich hier kurzes feedback dazu

LG
Christian