Anlage Benutzer Die Mail-Adresse wird bereits verwendet

german

#1

Hallo,
komisches Problem…
Bei der Anlage eines Users “webmaster” wird mir folgender Fehler gemeldet:

Das LDAP-Objekt konnte nicht gespeichert werden: Die Mail-Adresse wird bereits verwendet.

Ich kann die Adresse webmaster@ in der LDAP aber nirgendwo finden, sonst würde ich den entsprechenden User ja verwenden.
Wir haben die Mailadresse jedenfalls meines Wissens nie angelegt.
Hat jemand ne Idee, was hier los sein kann, oder wo sich die blöde Adresse versteckt haben könnte?

Danke
Sascha


#2

hmm, vllt. in der /etc/aliases:

root@master:~# ucr search webmaster mail/alias/webmaster: root Variables in the format mail/alias/USERNAME=EMAILADDRESS allow the configuration of a mail forwarding for the mail accounts of local users.

Ich würde mal ein ucr unset mail/alias/webmaster ausprobieren - einfach als Bauchgefühl.


#3

hi

das war n guter hint, leider ohne happy end.

[code]ucr search webmaster
mail/alias/webmaster: root
Variables in the format mail/alias/USERNAME=EMAILADDRESS allow the configuration of a mail forwarding for the mail accounts of local users.

ucr unset mail/alias/webmaster
[/code]

Trotzdem bei der Anlage des users “webmaster” weiterhin

und da der User “root” ja auch nicht in der LDAP zu finden ist, kann ich dort auch keine weiteren webmaster@ adressen als alternative Mailadressen anlegen, was aber eigentlich der Plan war.
Also wartung@maildomain2.de,wartung@maildomain3.de etc.

Danke
Sascha


#4

tut mir leid, dann bin ich als ucs-rooky raus.


#5

kein Problem, immerhin weiss ich jetzt etwas mehr als vorher ! :wink:


#6

Hallo.

Auf meinen Test-Systemen kann ich das Problem nicht nachvollziehen. Könnten Sie bitte folgendes ausführen:

univention-ldapsearch '(|(mailPrimaryAddress=webmaster*)(mailAlternativeAddress=webmaster*))' DN mailPrimaryAddress mailAlternativeAddress

Gruß
Daniel Tröder


#7

Hi,

also da ergibt sich was:

[code]
univention-ldapsearch ‘(|(mailPrimaryAddress=webmaster*)(mailAlternativeAddress=webmaster*))’ DN mailPrimaryAddress mailAlternativeAddress

extended LDIF

LDAPv3

base <dc=foo,dc=bar> (default) with scope subtree

filter: (|(mailPrimaryAddress=webmaster*)(mailAlternativeAddress=webmaster*))

requesting: DN mailPrimaryAddress mailAlternativeAddress

EMail webmaster-at-foo.bar, groups, foo.bar

dn: cn=EMail webmaster-at-foo.bar,cn=groups,dc=foo,dc=bar
mailPrimaryAddress: webmaster@foo.bar

search result

search: 3
result: 0 Success

numResponses: 2

numEntries: 1[/code]

Das Ding war also als Gruppe angelegt…
Danke, das hat geholfen!

lg
Sascha