AD irgendwie zerschossen nach backup2master-Migration

german

#1

Sorry, eine bessere Überschrift ist mir nicht eingefallen. :wink:

Nach dem Umzug eines PDC (durch Aufsetzen eines BDC mit anschließender Durchführung von backup2master, siehe [url]Bestehenden PDC ersetzen - wie?]) habe ich nun das Phänomen, dass sich kein Benutzer mehr am AD anmelden kann. Egal ob bestehender/migrierter oder neuer Benutzer. Zuerst kam bei allen die folgende Meldung:

root@hera:/etc/samba# smbclient --Utest -L //hera Enter test's password: session setup failed: NT_STATUS_INVALID_SID
Gesucht, gegoogelt, herausgefunden, dass die SID, die er gesucht hat, dem DC gehörte. Lösung:

net cache flush

Hiernach geht nun aber gar keine Samba-Anmeldung mehr am DC. Fehlermeldung ist jetzt NT_STATUS_CONNECTION_REFUSED. Egal welcher User, egal welches Kennwort, egal wann geändert oder welches Ablaufdatum. In den Samba-Logs des DC taucht gar nichts mehr auf, Loglevel hochdrehen beim smbclient ergibt auch nix.

Ich vermute, dass beim Konfigurieren des Univention AD DC - Pakets irgendwas schiefgelaufen ist. In der UMC und der UCR zeigt mir alles an, dass der neue Server ein DC Master ist. Dagegen spricht aber folgendes:

root@hera:~# /etc/init.d/samba restart [ ok ] Stopping NetBIOS name server: nmbd. [ ok ] Starting NetBIOS name server: nmbd. [ ok ] Stopping SMB/CIFS daemon: smbd. [ ok ] Starting SMB/CIFS daemon: smbd. [ ok ] Stopping Samba AD DC daemon: samba. Samba is not configured as AD DC.
Und das ist jetzt der Punkt, an dem ich nicht mehr weiterkomme. Hilfe. Bitte. :wink:

Schonmal danke und eine wunderschöne Arbeitswoche
HolleH


#2

Moin,

bitte pasten Sie doch mal die Ausgabe der folgenden Befehle:

[ol][li]ucr get server/role[/li]
[li]ucr get samba4/role[/li]
[li]testparm (hier reicht der Anfangsteil, also bis zur Meldung »press enter…«)[/li][/ol]

Gruß,
mosu


#3

Ach ja: die beim Hochstufen erstellte Logdatei /var/log/univention/backup2master.log wäre ebenfalls interessant.

Gruß,
mosu


#4

Hallo,

die server/role war “domain controller” (o.ä.), hatte ich geprüft. Ich habe allerdings, da ja keine Authentifizierung mehr möglich war, das Backup von vor backup2master wieder restored und zusammen mit dem alten PDC wieder in Betrieb genommen.

Ich habe die Vermutung, dass es irgendwie damit zusammenhängt, dass das Paket “AD-kompatibler Domain-Controller” beim Promovieren des BDC auf selbigem nicht installiert war. Ich führe die ganze Prozedur kommendes Wochenende nochmal durch und hoffe, dass es diesmal glattgeht. Falls nicht, würde ich mich hier mit den notwendigen Infos melden.

Danke erstmal soweit & viele Grüße
HolleH


#5

Hallo,

der Vollständigkeit halber: Zuerst auf dem BDC die selben Pakete installieren wie auf dem PDC (so wie’s auch im Manual steht :-/), dann klappt’s auch mit der Transition.

Danke & VG
HolleH