4.2 Domain Join Script Fails

From 4.1.0-errata-408
Removed two Apps that haven’t been updated yet to support 4.2.x.

Ran Upgrade successfully with reboots as needed. This one last domain join script fails:

RUNNING 33univention-portal.inst
2017-04-05 17:01:21.701046982-05:00 (in joinscript_init)
Object exists: cn=portal,cn=univention,dc=myhost,dc=com
Object exists: cn=portal,cn=custom attributes,cn=univention,dc=myhost,dc=com
Object exists: cn=domain,cn=portal,cn=univention,dc=myhost,dc=com
Object exists: cn=umc-domain,cn=portal,cn=univention,dc=myhost,dc=com
Object exists: cn=local,cn=portal,cn=univention,dc=myhost,dc=com
Object exists: cn=umc-local,cn=portal,cn=univention,dc=myhost,dc=com
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/label
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/label/de
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/label/fr
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/description
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/description/de
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/description/fr
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/icon
Not updating ucs/web/overview/entries/admin/ucs-local-to-domain/link
E: object not found

Hi all,

the same happened in our environment. Accessing the UMC via Webbrowser it leads to an endless redirection.

best regards


Hi everyone,

This is an error message that occurs if UDM tries do modify a non-existant object. Might be some sort of race condition, but I’m not sure. You should try to execute the pending joinscript again and see if it succeeds now:


Restarting the join script manually repeats the error message and exitcode 3.

Unfortunately it’s not a race condition.

I have a backup DC machine and completed the 4.2 migration with no issues. Going back to the main UCS machine, I restarted the server, then re-ran the script. It still failed with the same error.

What steps need to be taken to identify the missing object or remove the missing object being referenced?


Looking at the join script, it seems that the LDAP object cn=ucs-local-to-domain,cn=portal,cn=univention,<ldap_base> does not exist on the system. Can you confirm that?

A little bit about the background… UCS 4.2 has a UCR module which migrates UCR entries that match ucs/web/overview/entries/.* (i.e. previous entries which where displayed on the UCS overview page in UCS 4.1) into LDAP portal entry objects. The join log states that the UCR variables ucs/web/overview/entries/admin/ucs-local-to-domain/.* are already set. Therefore, the UCR module is not triggered and thus the LDAP portal entry object is not being created.

To make sure that the object is created, you can force to set the overview UCR variables anew with the following piece of code:

python <<EOF
import sys
from univention.appcenter.ucr import ucr_keys, ucr_instance
import create_portal_entries
import re
ids = set()
for key in ucr_keys():
    match = re.match("ucs/web/overview/entries/(admin|service)/([^/]+)/.*", key)
    if match:
changes = dict((id, (None, None)) for id in ids)
create_portal_entries.handler(ucr_instance(), changes)

If you run univentin-run-join-scripts after that again, it should succeed.

Hope that helps.


I ran:

  1. univention-ldapsearch ALL > ldap-dump.txt

  2. grep ucs-local-to-domain ldap-dump.txt zero results returned

  3. Created the Python script above and ran in terminal. Exited normally

  4. Re-ran the 33univention-portal LDAP script via the https gui. This time, it ran successfully.

  5. Restarted the https services, logged back in, and verified all scripts.


Thank you!


Hi Klaeser,

I’ve been having the same problem and also tried using the code you gave but the still the problem still exists,

UNNING 51nextcloud-uninstall.uinst
2018-09-11 09:40:06.079928556+08:00 (in joinscript_init)
WARNING: cannot remove Nextcloud from service, value does not exist
No modification: cn=ad,cn=dc,cn=computers,dc=holyspirit-manila,dc=intranet
E: object not found

__JOINERR__:FAILED: /usr/lib/univention-install/51nextcloud-uninstall.uinst

Tue Sep 11 09:40:07 +08 2018
univention-run-join-scripts finished

can you also help me with this? Thank you

Your problem is with a completely different join script than the original reporter’s, therefore the underlying cause will certainly be different. You should really create a new thread for your problem.