3.2-8 errata403, Paketupgrade deinstalliert samba4 usw

german

#1

Hallo Zusammen,

ich bin gerade dabei ein etwas angestaubtes UCS-System (3.2-8 errata403) auf Stand zu bringen.

Ich installiere vor dem jeweils nächsten Point-release immer erst die Paketupgrades. Jetzt will aber das Paketupgrade zu 3.2-8 errata403 diverse Pakete deinstallieren bei deren Deinstallation ich mich nicht wohlfühle (u.a. samba4, samba-ad-dc).

[code]Starting univention-upgrade. Current UCS version is 3.2-8 errata403

Checking for local repository: none
Checking for release updates: found: UCS 3.3-0

Do you want to update to 3.3-0 [Y|n]? n

Checking for package updates: found

The following packages will be REMOVED:
samba4,samba-ad-dc,libsmbd0,samba4-clients,libsamba-policy0,libnetapi0,libdcerpc-server0,libregistry0,libdcerpc0,libsmbclient-raw0,libgensec0,libsamdb0,libndr-standard0,libsamba-credentials0,libndr0,libsamba-hostconfig0,libsamba-util0
The following packages will be installed:
samba-libs,libaio1,samba-vfs-modules
The following packages will be upgraded:
univention-samba-local-config,univention-samba4,univention-samba4-sysvol-sync,libc6-i386,libc-dev-bin,libc6-dev,libc-bin,libc6,linux-libc-dev,winbind,python-samba,samba,libwbclient0,libssl0.9.8,slapd,ldap-utils,libldap-2.4-2,libtalloc2,libpython2.6,python2.6,python2.6-minimal,python-tdb,libtdb1,libtevent0,univention-directory-manager-tools,python-univention-directory-manager,python-univention-directory-manager-cli,univention-s4-connector,python-univention-connector-s4,samba-dsdb-modules,smbclient,libsmbclient,samba-common-bin,python-ldb,libldb1,python-talloc,samba-common,tdb-tools,ldb-tools,univention-kernel-image,gpgv,gnupg,cpio,isc-dhcp-server-ldap,isc-dhcp-server,isc-dhcp-client,isc-dhcp-common,libxml2,dnsutils,bind9,bind9-host,libisc84,libisccc80,libisccfg82,liblwres80,bind9utils,libdns88,libbind9-80,locales,openssh-server,openssh-client,grub-pc,grub-pc-bin,grub2-common,grub-common,libpq5,libtiff4,nscd,openssl,postgresql-client-8.4,postgresql-client,sudo,univention-errata-level,univention-grub,univention-management-console-frontend,univention-management-console-module-udm,univention-management-console-module-updater,univention-updater,univention-management-console-web-server,univention-directory-listener,univention-nagios-client,univention-nagios-common,univention-mail-postfix

Do you want to continue [Y|n]? n
[/code]

Wenn ich per aptitude die Updates ansehe scheint die Ursache ein Upgrade diverse Samba-Pakete von 4.1 auf 4.3 zu sein (Pakete samba, samba-common usw.).

Ist das Normal? Mir scheint das ein ungewöhnlich großer Sprung (Samba 4.1 auf 4.3) für ‘nur’ Paket-Upgrades.

Außer 15_ucs-online-version.list und 20_ucs-online-component.list sind keine weiteren Paketquellen aktiv. Ich hatte allerdings zeitweise ein opsi4ucs auf dem System installiert, die Pakete habe ich aber schon deinstalliert und auch aus den Paketquellen ausgetragen.

Hat das jemand schonmal so gesehen?

danke!
Nils


#2

Hallo,

Im Errata-Repository sind sowohl 4.1.0 als auch 4.3.7 Pakete.
Ich komme nicht vollständig hinterher, aber auch für 3.2.8 gab es in letzter Zeit Backports, unter anderem für [bug]41517[/bug].

Freundliche Grüße,
Dirk Ahrnke